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8 Payroll
8.1 Payroll Overview

With the Payroll feature, you can pay your employees’ salaries easily and securely.

In a single transaction, you can pay the salaries of multiple employees with accounts within 
Baiduri Bank or at other local banks.

To view a video tutorial on how to manage payroll, click here.

https://youtu.be/ES7Vt8myqMs
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iFILE is another available format which is typically generated from a Company’s HR Payroll
system. See sample below:

8 Payroll
8.2 Preparing Your Payroll

You can upload the payroll file using iFILE or CSV formats. You will need to prepare the payroll 
details in the same format as the sample payroll file, which can be downloaded when you create 
the payroll. Save the payroll file as an Excel Spreadsheet in CSV format only.

Sample of Payroll File

Important:

*In the excel spreadsheets, ensure account numbers are inputted in full with leading zeros.
Include an apostrophe at the beginning of the account number, for example ‘0100100123456

*Ensure employee names inputted fully match their names with their bank account. This will help to avoid the system 
rejecting transactions. Please make sure that employee names do not exceed 35 characters.

Sample of payroll file - Notepad

Sample of payroll file
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8 Payroll
8.3 Create Payroll

From the menu, go to Payroll → Create Payroll. The Create Payroll screen should be displayed.

Payroll details

Download the sample file in the chosen format.

Enter the file name. This is a summary of the payroll details for the 
customer's reference only.

Upload your Payroll File
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Payroll Header fields

8 Payroll
8.3 Create Payroll
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Once all details are entered, the following screen will appear.

8 Payroll
8.3 Create Payroll
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8 Payroll
8.3 Create Payroll

Review the Payroll Details

Click the CONTINUE button. The request will be reflected on the Review screen. The number of
transfers to be made within Baiduri Bank and other local banks will be indicated after verified by
the system. Rejected records will also be indicated here.
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8 Payroll
8.3 Create Payroll

Complete

Click PROCEED TO SUBMIT. A confirmation message will be prompted.

• The payroll file will then be sent to the View Upload File.

• The uploaded file details can be viewed in View Upload File by the Maker and the Approver.

• The uploaded file is subjected to the Batch job process.
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8 Payroll
8.3.1 View Upload File

View Upload File

Once the payroll file is uploaded and submitted, the details can be viewed under View Upload
File in the menu. Here, maker can view the status of the payroll file, whether they are pending
approval, being processed or failed.

From the menu, go to Payroll → View Upload File. The View Upload File screen should be displayed.

User can also view rejected payrolls error statuses under View Upload File → Record Details  
→ Rejected Records Summary
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8 Payroll
8.3.1 View Upload File

View upload file fields
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Enter all or any one of the above fields, then click the SEARCH button, the search results should
be displayed on the screen.

The payroll file sent for the verification process can be viewed here. The request will be moved to the Approval Workflow 
for the Approver to review after 5 to 10 minutes.

8 Payroll
8.3.1 View Upload File
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8 Payroll
8.4.1 Approve Payroll

All records under Manage Workflow will have Pending Approval status. Once they have been
approved, their status will be changed to Fully Approved.

From the menu, go to Payroll → Manage Workflow. The View Upload File screen should
be displayed.

Status

• Pending Approval: When payments are prepared by the Maker and submitted for approval

• Fully Approved: When the Approver approves the upload. The records will be pending to be released.
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8 Payroll
8.4.1 Approve Payroll

Manage Workflow functions
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Under the Action column, click the drop-down arrow, the sub-menu containing Approve and
Reject should be displayed.

Click Approve. The Approve Payroll screen should be displayed. Here, you can verify information
that was inputted.

A notice about the processing status will be prompted. Click X to proceed with approvals.

8 Payroll
8.4.1 Approve Payroll
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Click the Approve button. The 2FA authentication screen should be displayed. Here is where the
approval process step is done. Enter the OTP generated via digital token.

Click SUBMIT. A confirmation message should be prompted and the payroll is approved.

8 Payroll
8.4.1 Approve Payroll

Digital token
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From the menu, go to Payroll → Manage Workflow. The View Upload File screen should
be displayed.

Under the Action column, click the drop-down arrow, the sub-menu containing Approve and
Reject should be displayed.

Click REJECT. The Reject Payroll screen will be displayed. Enter notes or reasons regarding the
reason for rejecting the payroll in the Remarks field.

Click the REJECT button. 2FA is required to complete the process.

8 Payroll
8.4.2 Reject (Payroll)
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8 Payroll
8.5 Payroll List

This section contains all statuses of transactions after the payroll file has been approved by the 
Approver. This includes records that have been successfully approved and processed, records that 
have failed, records that are set to be processed on a future date, and records that are currently 
being processed.

There are two types of payrolls under Payroll List:

Before Batching
All payrolls under this page are auto-validated and prepared for processing. If payroll file fails, the 
Maker will need to re-submit a new payroll.
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8 Payroll
8.5 Payroll List

After Batching
The payrolls on this page have been processed and/or is ready for transfer.

Stop Future Dated Payroll

Under the After Batching payroll type, an Approver can stop a Future Dated Payroll.

Definition of statuses under After Batching Type:-

• Success – Payroll has been transferred successfully

• Stopped – Payroll was stopped

• Future Dated – Payroll is ready for processing on the specified payment date

• Pending Processing – Payroll is pending to be processed by the Bank

• Processed with failure/Failed – Some or all transactions failed during processing. Click on
  the Payroll Batch Reference link to view details of the successful and failed transactions
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8 Payroll
8.6 Payroll (USD to USD)

With the Payroll feature, you can pay your employees' salaries easily and securely. Adding a new 
transaction to the payroll feature allows you to use USD to USD internal accounts for payroll.

Preparing your Payroll

From the menu, go to Payroll → Create Payroll

The maker is required to fill in the payroll details:

• Payroll format - A dropdown menu where
  the maker can select either iFile or CSV file format.
• Upload type - Enter a description for your file 
  (alphanumeric characters only).
• Sample file - This is an optional step where the 
  maker can download a sample payroll file.
• Browse - Click this button to select the file you 
  want to upload.

You can upload your payroll data in CSV format. You will need to prepare the payroll details in the 
same format as the sample payroll file, which you can download when you create a new payroll. 
Save the payroll file as a CSV file.

Sample of Payroll File
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iFile is another available format, typically generated by a company's HR payroll system. See the 
sample file below:

Important:

Account Numbers
• Enter account numbers in full, including leading zeros. For example, enter '0100100123456' instead 
  of 100100123456.

Employee Names
• Ensure employee names entered match exactly with their bank account names. This helps avoid 
  rejected transactions.
• Please note that employee names cannot exceed 35 characters.

8 Payroll
8.6 Payroll (USD to USD)
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8 Payroll
8.6 Payroll (USD to USD)

Create Payroll

From the menu, go to Payroll → Create Payroll. The create payroll screen will appear.

Payroll details
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Payroll Header Fields

8 Payroll
8.6 Payroll (USD to USD)

Once all details are entered, 
the maker can continue to 
the review page.
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8 Payroll
8.6 Payroll (USD to USD)

Review the Payroll details

• Click the Continue button. Your request will be reflected on the Review screen.

• The following details will be displayed:

		  • Debit account
		  • Payment records
		  • Number of records
		  • Currency
		  • Total amount
		  • Fees (in BND)

• If there are no errors, click Continue to Submit to upload the file for processing.
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Click Proceed to Submit to initiate the upload process. A confirmation message will then appear.

8 Payroll
8.6 Payroll (USD to USD)

View upload file

Once you upload and submit your payroll file, you can track its status using the View Upload File 
menu option. This section allows you to see if your file is:

•	 Being processed
•	 Failed

From the menu, go to Payroll → View Upload File.  The View Upload File screen will then appear.

You can also view specific error details for rejected payrolls under View Upload File → Record → 
Rejected Records Summary.
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8 Payroll
8.6 Payroll (USD to USD)

Payroll process progress and Status:

Maker can track the progress of the payroll file using the "View Upload File" function:

Go to Payroll → View Upload File. The View Upload File screen will then appear.

Once your file is processed, you can check the final status (success or failure) in the View 
Upload List. The processing time typically takes 2-3 minutes, depending on the number of 
records in your file.

Enter any or all of the above fields in the search bar and click SEARCH to view the results on screen.

View Upload File Fields
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Failure within View Upload List: 

If the payroll upload fails to process, the status will change to Failed. The Maker can then click on 
the reference hyperlink to view the reason(s) for the failure.

8 Payroll
8.6 Payroll (USD to USD)
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8 Payroll
8.6 Payroll (USD to USD)

Payroll List

This section provides an overview of all payroll transaction statuses, both before and after the 
payroll file has been approved by the Approver. This includes records that have been:
 
•	 Successfully approved and processed
•	 Processed with errors (failed)
•	 Scheduled for future processing
•	 Currently being processed

The Payroll List displays two main types:

Before Batching
In this stage, all payrolls undergo automatic validation and are prepared for processing. If a 
payroll file fails validation, the Maker will need to resubmit a new payroll file.
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After Batching
Payrolls on this page have been processed and are now ready for transfer.

Definition of statuses under After Batching Type:

• Future dated – Payroll is scheduled for processing on the specified payment date.
• Stopped – Payroll processing was stopped.
• Sent to bank – Payroll has been sent to bank for processing. 
• Failed – Transaction failed during processing. Click the Payroll Batch reference link to view details   
  of failed transactions.

Stop Future Dated Payroll
An Approver can stop a future dated payroll under the "After Batching" category.

8 Payroll
8.6 Payroll (USD to USD)
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8 Payroll
8.6 Payroll (USD to USD)

Approve Payroll

All records under Manage Workflow will initially have a Pending Approval status. Once 
approved, the status will change to Fully Approved.

To view and manage your payroll submissions, go to Payroll and then Manage Workflow. This 
will display the View Upload File screen.

Status

• Pending Approval: This status indicates that payments have been prepared by the Maker 
  and submitted for approval.

• Fully Approved: The Approver has approved the upload. The records are now awaiting release.
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In the Action column, click the dropdown arrow to reveal a submenu with Approve and Reject 
options.

Click Approve to proceed. The Approve Payroll screen will then appear, allowing you to verify the 
entered information before finalising.

8 Payroll
8.6 Payroll (USD to USD)

Manage Workflow functions
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8 Payroll
8.6 Payroll (USD to USD)

Important note: Even if the payroll payment date has passed its due date, the Approver can 
still approve it for processing on the next working day. However, to proceed with approval, the 
user will need to close (click the X) on the past payment date notification.

Click Approve to proceed. You will then be prompted for Two-Factor Authentication (2FA) to 
verify your identity. Enter the One-Time Password (OTP) generated by your digital token.
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After reviewing the payroll details, the Approver can proceed to generate the Two-Factor 
Authentication (2FA) by using the physical token or soft token to process the transaction.

Click SUBMIT to process the transaction. A confirmation message will then be displayed indicating 
successful payroll approval.

8 Payroll
8.6 Payroll (USD to USD)
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To navigate to the payroll status

Makers and Approvers can go to Dashboard > Financial > Transaction statistics. 
Under the Filter menu, select Payroll. Then, choose the desired dates using the provided filters for 
payroll creation and payment dates. This will display the User Workflow and the Bank Workflow.

8 Payroll
8.6 Payroll (USD to USD)
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